About Deprecations in This Version of Puppet

Included in Puppet Enterprise 2015.3. A newer version is available; see the version menu above for details.

About Deprecations in Puppet 4.x

Puppet 4.0 removed or changed a lot of old and crufty features that had a long period of deprecation in Puppet 3.x (or sometimes even earlier). Now it’s time for the next wave of improvements to the Puppet codebase.

While the 3.x deprecations focused mostly on the Puppet language and longstanding problems with built-in resource types, the 4.x deprecations will focus on Puppet’s infrastructure.

How to Tell Whether You’re Using Deprecated Features, and What to Do Next

As Puppet 5 gets closer, you should read through the deprecation pages in this section. Each page will group similar features together, and each feature will explain what to do if you’re affected.

↑ Back to top