Puppet 4.1 System Requirements

This version of Puppet is not included in Puppet Enterprise. The latest version of PE includes Puppet 4.10. A newer version is available; see the version menu above for details.

To install Puppet 4.1, first view pre-install tasks.

Hardware

The Puppet agent service has no particular hardware requirements and can run on nearly anything.

However, the Puppet master service is fairly resource intensive, and should be installed on a robust dedicated server.

  • At minimum, your Puppet master server should have two processor cores and at least 1 GB RAM.
  • To comfortably serve at least 1000 nodes, it should have 2-4 processor cores and at least 4 GB RAM.

The demands on the Puppet master will vary widely between different deployments. The total needs are affected by the number of agents being served, how frequently those agents check in, how many resources are being managed on each agent, and the complexity of the manifests and modules in use.

Platforms With Packages

Puppet 4.1 and all of its prerequisites will run on the following platforms, and Puppet Labs provides official packages in our package repositories.

Red Hat Enterprise Linux (and Derivatives)

We publish and test official puppet-agent packages for the following versions of Red Hat Enterprise Linux (RHEL):

This information applies to RHEL itself, as well as any distributions that maintain binary compatibility with it, including but not limited to CentOS, Scientific Linux, and Oracle Linux.

Debian and Ubuntu

We publish and test official puppet-agent packages for the following versions of Debian:

  • Debian 8 “Jessie” (current stable release)
  • Debian 7 “Wheezy” (previous stable release)
  • Debian 6 “Squeeze”

We also publish and test official puppet-agent packages for the following versions of Ubuntu:

  • Ubuntu 15.04 “Vivid Vervet”
  • Ubuntu 14.04 LTS “Trusty Tahr”
  • Ubuntu 12.04 LTS “Precise Pangolin”

Fedora

We publish and test official puppet-agent packages for the following versions of Fedora:

  • Fedora 21
  • Fedora 20

Windows

We publish and test official puppet-agent packages for the following versions of Windows:

We also publish, but do not automatically test, puppet-agent packages for the following versions of Windows:

Mac OS X

  • A package for Mac OS X, version 10.9 (Mavericks) and higher will be available at a later date.

Platforms Without Packages

Puppet and its prerequisites are known to run on the following platforms, but we do not provide official packages and do not perform automated testing.

Other Linux

  • SUSE Linux Enterprise Server, version 11 and higher
  • Gentoo Linux
  • Mandriva Corporate Server 4
  • ArchLinux

Other Unix

  • Oracle Solaris, version 10 and higher (Puppet Labs performs limited automated testing on Solaris 11.)
  • AIX, version 5.3 and higher
  • FreeBSD 4.7 and later
  • OpenBSD 4.1 and later
  • HP-UX

Basic Requirements

If you’re installing Puppet via the official packages, you won’t need to worry about these prerequisites; your system’s package manager will handle all of them. These are only listed for those running Puppet from source or on unsupported systems.

Puppet 4.1 has the following prerequisites:

Ruby

Use one of the following versions of MRI (standard) Ruby:

  • 2.1.x
  • 2.0.x
  • 1.9.3

Note: We currently only test and package with 2.1.x versions of Ruby, therefore we recommend you only use this version. Other interpreters and versions of Ruby are not covered by our tests, and may or may not work.

Mandatory Libraries

Optional Libraries

↑ Back to top