Puppet 3.5 System Requirements

This version of Puppet is not included in Puppet Enterprise. The latest version of PE includes Puppet 4.10. A newer version is available; see the version menu above for details.

To install Puppet 3.5, see the Puppet installation guide.

Platforms With Packages

Puppet 3.5 and all of its prerequisites will run on the following platforms, and Puppet Labs provides official packages in our package repositories.

Red Hat Enterprise Linux (and Derivatives)

We publish official packages and run automated testing on the following versions:

Puppet Enterprise also supports RHEL 4, which does not receive packages for open source Puppet.

(Note that RHEL 5 requires an updated Ruby ≥ 1.8.7 from our yum repo.)

This information applies to RHEL itself, as well as any distributions that maintain binary compatibility with it, including but not limited to CentOS, Scientific Linux, Oracle Linux, and Ascendos.

Debian and Ubuntu

We publish official packages and run automated testing on the following versions:

Fedora

We publish official packages and run automated testing on the following versions:

  • Fedora 24
  • Fedora 23

Windows

We publish official packages and run automated testing on the following versions:

We publish packages for the following versions, but do not run automated testing on them:

Mac OS X

Although we publish packages for Mac OS X, we do not run automated testing on it.

  • Mac OS X, version 10.6 (Snow Leopard) and higher

Platforms Without Packages

Puppet and its prerequisites are known to run on the following platforms, but we do not provide official packages and do not perform automated testing.

Other Linux

  • SUSE Linux Enterprise Server, version 11 and higher
  • Gentoo Linux
  • Mandriva Corporate Server 4
  • ArchLinux

Other Unix

  • Oracle Solaris, version 10 and higher (Puppet Labs performs limited automated testing on Solaris 11.)
  • AIX, version 5.3 and higher
  • FreeBSD 4.7 and later
  • OpenBSD 4.1 and later
  • HP-UX

Basic Requirements

If you’re installing Puppet via the official packages, you won’t need to worry about these prerequisites; your system’s package manager will handle all of them. These are only listed for those running Puppet from source or on unsupported systems.

Puppet 3.5 has the following prerequisites:

Ruby

Use one of the following versions of MRI (standard) Ruby:

  • 2.1.x — Note: We run spec tests for Ruby 2.1, but since none of our tested platforms ship with it yet, we don’t run acceptance tests on it. This means we think it’s good, but it might have problems we don’t know about yet.
  • 2.0.x
  • 1.9.3
  • 1.8.7

Other interpreters and versions of Ruby are not covered by our tests, and may or may not work.

Mandatory Libraries

  • Facter 1.7.0 or later
  • Hiera 1.0 or later
  • The json gem (any modern version).

Optional Libraries

↑ Back to top