Hiera 3.2: Release Notes

Included in Puppet Enterprise 2016.5. A newer version is available; see the version menu above for details.

###Note: We’ve released a major update to Hiera called Hiera 5.

It’s built into Puppet 4.9 and higher, and includes features like per-environment hierarchies, module data, simplified custom backends, improved debugging with puppet lookup --explain, and more.

As part of this update, we’ve moved Hiera’s documentation into the Puppet reference manual. Once you’ve upgraded to Puppet 4.9 or higher, see the following pages for more info about the new Hiera:

Hiera 3.2.2

Released November 1, 2016.

Minor bug fix release shipped in puppet-agent version 1.7.2 and 1.8.0.

Hiera 3.2.1

Released August 10, 2016.

Minor bug fix release shipped in puppet-agent version 1.6.0.

Bug fixes

  • HI-528: Hiera 3.2.x does not support Rubies < 1.9.3. The dependencies on ‘json’ and ‘json_pure’ has therefore been dropped from hiera’s gemspec to make it easier to consume hiera as a gem.

Hiera 3.2.0

Released May 17, 2016.

Shipped in puppet-agent version 1.5.0.

New default location for hiera.yaml

The default location of hiera.yaml has changed from the $codedir to the $confdir. Updating via puppet-agent 1.5.0 packages will not move your existing file, but new installations will place it in this location. You need to manually move the file to $confdir.

↑ Back to top